пятница, 9 августа 2013 г.

Jenkins (и другие) откажутся от поддержки Java 5

Создатель сервера непрерывной интеграции Jenkins CI Косуке Кавагучи работает над интересной инициативой. Он призывает открытые проекты и разработчиков отказаться от поддержки Java 5. Хотя такое изменение окажется несущественным для большинства открытых проектов, оно окажет ощутимое влияние на серверы непрерывной интеграции вроде Jenkins.

Что?

Мы обязаны заявить: наши релизы после 30-го сентября 2013 года в качестве минимальной среды исполнения будут требовать Java 6. Мы хотим предупредить об этом наших пользователей. Чтобы достичь поставленных целей, мы объединяемся с открытыми проектами. Вся информация будет размещена на веб-сайте. Мы призываем людей распространять новости, а помогут им в этом названия и логотипы наших коллективных проектов.

Мы -- разработчики открытого проекта. Чтобы позволить пользователям применять наше ПО, до настоящего времени мы не требовали Java 6 в качестве минимальной среды исполнения. Однако, пришло время двигаться дальше.

Почему?

Доводов, на самом деле, очень много:
  • Многие поставщики виртуальной машины Java больше не поддерживают Java 5.
  • Отсутствие жизнеспособной открытой реализации Java 5.
  • Невозможность использовать библиотеки, требующие Java новых версий. Как результат, количество новых функций и исправлений уменьшается, а усилий на разработку уходит больше.
  • Повышаются затраты на интеграционное тестирование. Мы проводим больше тестов для Java 5, в то время, как все меньше разработчиков работают с ней.
  • Среды выполнения Java новых версий обладают богатым набором возможностей. Больше API коллекций, усовершенствования NIO, консольный доступ, поддержка XML, Java Compiler API, процессоры аннотаций и интерфейс скриптового языка.
  • Формат класс-файла версии 1.50 распространяется совместно с верификатором Split-Verifier, что позволяет ускорить загрузку классов.
  • Объединив усилия, мы сможем добиться увеличения количества пользователей.

Факты

  • Java 5 вышла в 2005 году, почти десять лет назад. в 2009 достигла стадии полного прекращения поддержки.
  • Даже IBM откажется от поддержки Java 5 на стороне сервера 30-го сентября 2013 года. 

Комментариев нет:

Отправить комментарий